Endlich heiß gebacken kriegen?

16 Jul

Der Pizzaofen-Sensor von Mr. J machte einige Zeit, was er sollte, dann machte er gar nichts mehr. Hier die Fortsetzung der Geschichte …

Die Rahmenbedingungen: Ein K-Typ Hochtemperatur-Sensor mit einem Meter Anschlussleitung, eingemauert im Backofen. Hat einige Monate ganz gut funktioniert, dann wurden die Messwerte mysteriös, und nach einem kleineren Umbau ging gar nichts mehr. Im Test-Aufbau auf der Werkbank mit anderen frischen Fühlern wurde es auch nicht mehr besser.

Naheliegende Schlussfolgerung? Chip beschädigt, evtl. statische Aufladung.

Also kam eine neuere Version mit mehr Beschaltung auf der Platine in den Warenkorb, und ein paar Wochen Warten begannen. Danach Umrüsten auf dem „Mainboard“ mit einem zusätzlichen Steckverbinder für die abweichende Kontaktleiste des neuen MAX31855-Moduls.

Zwischenzeitlich habe ich mich dann doch noch näher mit den Sensoren beschäftigt, und die Stör-Empfindlichkeit bei Verlängerungen scheint erheblich zu sein. Also: Nochmal Sensor nachbestellt, mit 3 Meter Zuleitung im Metallgewebe. Wieder Wochen weiter warten.

Dann also heute abend Versuchs-Aufbau. Und wenn wir schon dabei sind: Besser noch ein OLED dran anbringen, und einen Taster an Pin D3 des Wemos-Moduls, das erleichtert das Konfigurieren mit Homie-MQTT (im Sinne von "5 Sekunden halten im Betrieb für Werks-Reset“ – aber immer noch einfacher als den Laptop auf der Leiter mit USB im Schaltschrank anzustecken).

Allmählich wird die Platine eng, und das Modul braucht jetzt auch noch eine Frontblende für das Display. Neue Herausforderungen!

Und da wir die Software bei Mr. J auf seinem Desktop zusammengestellt haben, habe ich auch keinen Arduino-Quellcode, um die Erweiterung fürs OLED anzufügen.

Das war jetzt nicht ganz so durchdacht …

Ersatzweise muss ein frischer Wemos D1 ’ran. Nachdem die schlanke „Nur-Text“-Bibliothek für das Display eingebunden ist, wird es Zeit für den ersten Test.

Ergebnis? Null Grad mit dem neuen MAX-Modul und dem neuen Sensor. Das ist nicht schön.

Mehr zur Gegenprobe verbinde ich den Sensor mit dem alten Modul und stecke es ein. Und schon sind es 24 Grad. Innen wie Außen. Ein Feuerzeug unter dem Sensor lässt es deutlich kälter werden. Ah. Verpolt. Neu angeschlossen, und …

Es funktioniert! Das alte Modul mit dem neuen Sensor tut genau was es soll. Das fällt dann wohl unter die Rubrik „In den eigenen Hintern beißen wollen“. Merke: Beim nächsten Mal einfach einen Sensor mit der richtigen Kabellänge kaufen.

Was noch fehlt, ist eine Lösung für den Sensor im Ofen. Ich neige nun dazu, ein Eisen-Wasserrohr mit schraubbarer Endkappe vorzuschlagen, wo wir den Sensor in ein zu bohrendes Loch in der Kappe stecken. So muss Mr. J nicht für den wohl gelegentlich nötigen Verschleiß-Sensor-Tausch die Ofen-Isolier-Schüttung abräumen und Mörtel klopfen …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

2 × 3 =